Page 10 of 10 FirstFirst ... 8910
Results 181 to 186 of 186

Thread: noob here

  1. #181
    Join Date
    Sep 2013
    Location
    Bend, Oregon
    Posts
    436
    Like(s)
    44
    Liked 43 Times in 37 Posts

    Default

    Its improved quite a lot today, if i lay down awhile its horrible and i can't walk but then it warms up or something and I can kinda walk. Was able to drive.

    I have hopes it will be ok by the time my new Mototrax kit gets here

  2. #182
    Join Date
    Sep 2013
    Location
    Bend, Oregon
    Posts
    436
    Like(s)
    44
    Liked 43 Times in 37 Posts

    Default






  3. #183
    Join Date
    Feb 2008
    Location
    the burg
    Posts
    2,621
    Like(s)
    22
    Liked 129 Times in 102 Posts

    Default

    So that's what a $6000 box looks like

  4. #184
    Join Date
    Sep 2013
    Location
    Bend, Oregon
    Posts
    436
    Like(s)
    44
    Liked 43 Times in 37 Posts

    Default

    5.. but yea.

    They sent me some wrong parts so i dont have it installed yet.

  5. #185
    Join Date
    Sep 2013
    Location
    Bend, Oregon
    Posts
    436
    Like(s)
    44
    Liked 43 Times in 37 Posts

    Default

    They sent the wrong strut with my fit kit...so waiting on the correct one, should be here monday.. just in time to miss the 3 day weekend LOL. and my foot is finally better. Oh well I'll take the sled out this weekend.

    Did some cleaning and some of the install, my helper "Bubba" likes to get into pictures.







    Getting the swingarm axel through bymyself was difficult, but getting the last 2 bolts to the strut was even harder.. till I came up with this ladder/ratchet strap idea... unfortunatly thats when I realized the strut they gave me was WAY too short.



    Put front ski on tonight.
    Last edited by KTMDirtFace; 02-17-17 at 09:10 PM.

  6. Post Likes:


  7. #186
    Join Date
    Sep 2013
    Location
    Bend, Oregon
    Posts
    436
    Like(s)
    44
    Liked 43 Times in 37 Posts

    Default

    More problems so far I'm not very happy.

    Chain adjuster wouldn't fit...somone told me it means my bulkhead was welded incorrectly and off square. I ground the adjuster down with an angle grinder and made it fit.


    Front Ski Fit kit is screwed up. The spacers stick out on the bikes right side, and only go half way into the axle hole on the left..so the pinch bolt doesnt even pinch half of it.





    Going to have to call them again and get more parts sent - new bulkhead probably, and new fit kit for sure for the ski.

Page 10 of 10 FirstFirst ... 8910

Similar Threads

  1. noob here...
    By Greengarage in forum General Snowmobiling
    Replies: 3
    Last Post: 01-05-12, 08:06 PM
  2. Dumb Noob Question
    By ChillyKen in forum General Snowmobiling
    Replies: 8
    Last Post: 12-10-10, 02:39 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •