Results 1 to 9 of 9

Thread: Sled back up and running. 09 M8

  1. #1
    Join Date
    Mar 2008
    Location
    Eagle Point, Oregon
    Posts
    947
    Like(s)
    24
    Liked 17 Times in 16 Posts

    Default Sled back up and running. 09 M8

    So last year my season was cut a bit short due to not being able to get a new steering shaft in time. Finished it today after it sitting on the counter over the summer, fresh snow can really motivate a person ya know! Any ways for those of you riding the AC M series and I am sure many more of their models, please be sure to check the steering shaft. Pics show where mine failed. Name:  ac break 002.jpg
Views: 274
Size:  138.7 KBName:  ac break 001.jpg
Views: 255
Size:  142.9 KBName:  ac break 003.jpg
Views: 171
Size:  142.9 KBName:  ac break 004.jpg
Views: 159
Size:  144.6 KB
    craterlandscape.com

  2. #2
    Join Date
    Feb 2008
    Location
    the burg
    Posts
    2,658
    Like(s)
    22
    Liked 129 Times in 102 Posts

    Default

    FORGET ABOUT THE DIAMOND DRIVE CHECK OUT THE STEERING POST!

    sorry just couldn't resist


    at least it wasn't glued together you need to bring up it my way on a weekend so we can ride!!!

  3. #3
    Join Date
    Nov 2008
    Location
    Eugene
    Posts
    777
    Like(s)
    33
    Liked 18 Times in 15 Posts

    Default Sled back up and running. 09 M8

    I also do by best work last minute, oh wait- I do ALL my work last minute!
    Polaris Pro 162" boosted
    Polaris Pro 155"
    OSSA, Walker Rim Snowmobile club:Crescent lake

  4. #4
    Join Date
    Jan 2012
    Location
    zimmerman minnesota
    Posts
    68
    Like(s)
    0
    Liked 0 Times in 0 Posts

    Default Sled back up and running. 09 M8

    Ok no more glue! Lets go back to old fashion welding! Another 3 oz of weight c'mon really!

  5. #5
    Join Date
    Mar 2008
    Location
    Eagle Point, Oregon
    Posts
    947
    Like(s)
    24
    Liked 17 Times in 16 Posts

    Default

    Yeah lucky it was not a boys ride when it broke. Simple day of riding with the family and all of the sudden I couldn't take a turn. Dang near went out of bounds in Crater Lake Park. All is good not greatly impressed with how AC handled it. Will be doing a follow up with them now that I have it removed. And yes I usually don't procrastinate but this was one of those times, thought I had a good month before I needed it fixed!!!!
    @ Sandman Never had a problem with the Diamond Drive. change fluids every year. should I be concerned?
    craterlandscape.com

  6. #6
    Join Date
    Mar 2008
    Location
    Eagle Point, Oregon
    Posts
    947
    Like(s)
    24
    Liked 17 Times in 16 Posts

    Default

    Quote Originally Posted by zookiracer View Post
    I also do by best work last minute, oh wait- I do ALL my work last minute!
    Yeah if its not down to the wire I don't do my best work Easier to find all the parts when you do it all at once!!!!!
    craterlandscape.com

  7. #7
    Join Date
    Feb 2008
    Location
    the burg
    Posts
    2,658
    Like(s)
    22
    Liked 129 Times in 102 Posts

    Default

    no real worries with the 09 and up, if you ever take it apart they do make what they call a wide bearing to replace the one main bearing that has been known to fail.

  8. #8
    Join Date
    Sep 2008
    Location
    Corvallis Oregon
    Posts
    279
    Like(s)
    3
    Liked 5 Times in 5 Posts

    Default

    Make sure the notch on the bottom of the post is in the slot. Mine had slipped out and then went in while riding. Made it really sloppy and I thought it broke again.
    2013 M1100T, 07 m8, 09 nytro, 97 zl500, 93 wildcat, 01 z120

  9. #9
    Join Date
    Mar 2008
    Location
    Eagle Point, Oregon
    Posts
    947
    Like(s)
    24
    Liked 17 Times in 16 Posts

    Default

    Quote Originally Posted by _DJ_ View Post
    Make sure the notch on the bottom of the post is in the slot. Mine had slipped out and then went in while riding. Made it really sloppy and I thought it broke again.
    Thanks did make sure of that. So was it your M8 that you broke? I have a call into them with no response as of yet. Getting little pissed. Might be my last AC product I buy.
    craterlandscape.com

Similar Threads

  1. Running board lights
    By 2011Rush600 in forum Polaris
    Replies: 8
    Last Post: 12-14-11, 08:04 PM
  2. Honda Trail 90 - Getting it Running
    By ben in forum Stuck Sled
    Replies: 8
    Last Post: 08-13-11, 03:47 PM
  3. Kapka EIS Comment period running out
    By SkiDooSnoChica in forum General Snowmobiling
    Replies: 1
    Last Post: 05-15-11, 05:37 PM
  4. Just got back from MT.
    By master in forum General Snowmobiling
    Replies: 9
    Last Post: 02-11-09, 08:14 PM
  5. running boards
    By J-Rad in forum Sleds / Tech
    Replies: 15
    Last Post: 02-27-08, 07:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •